Версия для печати

Документация для пользователей

open all | close all

Команды меню "Сервисы"

Команды меню "Сервисы"


Меню Сервисы предлагает следующие команды:


Сравнение документов

Этот пункт меню инициирует процедуру сравнения документов. Чтобы осуществить процедуру сравнения, следует предварительно открыть два документа. Процедура сравнения находит отличия в текущем активном документе по сравнению с другим документом. Список отличий выводится в окно "Служебная информация", на страницу "Процесс".
Если окно "Служебная информация" скрыто, можно открыть его, используя команду меню "Вид / Панели инструментов / Служебная информация".
В списке отличий действует контекстное меню, доступное по правой кнопке мыши. Команда контекстного меню "Выделить элемент" позволяет выделить в текущем активном документе тот элемент модели, который соответствует указанной строке списка отличий. Аналогичный эффект достигается двойны щелчком левой кнопкой мыши на строке в списке отличий.

Экспликация помещений

Команда инициирует диалог "Экспликация помещений". В диалоге приводится список помещений в проекте с указанием их площадей и объёмов. При расчёте площадей учитывается "Коэффициент площади", задаваемый в качестве параметра для каждого помещения. Например, 0.5 для балкона.

Спецификация материалов

Инициирует диалог "Спецификация материалов". В диалоге изображается таблица, в которой отображается список материалов всех элементов проекта по этажам. Для каждого материала приводится суммарный объём элементов, которым он назначен и указывается суммарная масса. В нижней строке таблицы приводится суммарный объём и суммарная масса всех элементов проекта, которым назначены материалы.

Основные надписи

Инициирует диалог управления автоматизированным заполнением основных надписей на чертёжных листах.
Диалог реализован в виде HTML-страницы. Автоматизированный сервис заполнения основных надписей реализлван в форме сценария. Сценарий доступен в виде исходного текста на javascript. Пользователь может вносить изменения в этот сценарий.

Маркировка

Команда инициирует сервисный сценарий для автоматической маркировки элементов проекта.

СНиП

Команда инициирует информационно-поисковую систему для получения подсказок из нормативной базы.

Спецификации

Команда инициирует диалог настройки параметров и запуска сценариев формирования спецификаций. Сценарии формирования спецификаций поставляются в виде исходных текстов программ, что позволяет модифицировать их силами сторонних разработчиков и опытных пользователей.

Диагностика объекта

Команда инициирует диалог управления сценарием диагностики модели проектируемого объекта. С помощью диалога можно настроить параметры сервисного сценария, выполняющего проверку элементов модели на корректность. Сервис рассматривает колонны, балки, стены, прилы перекрытия, проёмы и т.д. на предмет заданных им пользователем значений параметров, а также на предмет подозрительного взаиморасположения архитектурно-конструктивных элементов. В случае обнаружения потенциальных некорректностей сервис сигнализирует об этом пользователю посредством сообщений в служебном окне "Ошибки". Не всегда сообщение о потенциальной некорректности свидетельствует об ошибке. Обозначенная ситуация подлежит проверке со стороны пользователя. Чтобы локализовать потенциальную ошибку в модели, укажите строку в списке ошибок и выполните на ней двойной щелчок - упомянутый в сообщении объект будет выделен на изображении модели.

Линии и поверхности

Команда инициирует диалог и сценарии формирования пространственных линий и поверхностей. Диалог позволяет выбрать тип линии или поверхности и исполнить сценарий генерации линии или поверхности выбранного типа. Пользователь может создать свои типы линий и поверхностей путём ввода соответствующих формул в окне диалога.

МОНТАЖ

Команда инициирует подсистему "МОНТАЖ", если данная подсистема разрешена в текущей конфигурации САПФИР.
Для управления подсистемой предлагается одноимённый диалог. Средствами диалога "МОНТАЖ" можно создать набор событий монтажа и демонтажа, обозначить этапы возведения здания. При формировании расчётной схемы будут автоматически созданы монтажные таблицы и монтажные загружения в терминах ЛИРА-САПР 2013 (в файле S2L).

Меню "Сервисы" можно дополнять пользовательскими командами, можно редактировать названия команд, или удалять команды, которые не используются. Для этого выполните щелчок правой кнопкой мыши на панели меню в свободном от кнопок и пиктограмм месте. При этом появляется контекстное меню, в котором следует выбрать команду "Настроить...". Открывается окно диалога "Настройка". Выбираем в диалоге вкладку "Сервис" (см. рис. 1). На вкладке "Сервис" настраивается набор команд в меню "Сервис".

Рис.1.

© «САПФИР-3D» v.2013, 2013