Версия для печати

Документация для пользователей

open all | close all

Справочная информация о САПФИР

Справочная информация о САПФИР

Программа САПФИР


Программа предназначена для архитектурного проектирования, формообразования и расчётов.


Управление программой осуществляется при помощи команд меню и инструментальных панелей.

Проект - это документ программы САПФИР, который можно сохранить в файле с расширением *.spf. Проект в САПФИР представлен пространственной информационной моделью проектируемого объекта, набором видов документирования и набором листов чертежей.

Информационная модель проектируемого объекта включает в себя модели одного или нескольких зданий, расположенных в пространстве.
Модель каждого здания состоит из нескольких этажей, геометрически разделяющих пространство здания по высоте, логически объединяющих модели архитектурно-конструктивных элементов.


Работа над проектом происходит путём создания и редактирования трёхмерной модели проектируемого объекта. Модель изображается в графических видах с использованием центрального и ортографического проецирования: перспективы, аксонометрии, планы этажей, разрезы, фасады. Выбор активного графического вида выполняется при помощи закладок, расположенных в верхней части графических окон.


Для построения элемента модели каждого определённого типа служит специализированный (прикладной) инструмент. Свойства прикладного инструмента и, соответственно, параметры создаваемых и редактируемых элементов настраиваются с помощью управляющих элементов, представленных на панели свойств инструмента. Управляющие элементы перезагружаются в зависимости от типа выбранного инструмента. Выбор инструментов осуществляется при помощи кнопок на панели "Инструменты".


Для ввода точек используется трёхмерный локатор, управляемый мышью. Локатор изображается в графических видах в соответствии с установленным режимом проецирования. Текущие координаты локатора отображаются в строке состояния и в окне координат.
Используйте комбинации клавиш для оперативного управления и позиционирования локатора.


Для указывания объектов, изображённых в графических видах, используется курсор, управляемый мышью. Указывание объектов приводит к их выделению для редактирования. Выделенные объекты отмечаются цветом выделения. Свойства выделенного объекта редактируются с помощью управляющих элементов инструментального диалога. Развыделить все элементы поможет комбинация клавиш Ctrl R и(или) в некоторых ситуациях (опционно) клавиша Esc, будучи нажатой дважды.


Команды


Меню "Файл"


Меню "Создать"


Меню "Редактор"


Меню "Вид"


Меню "Окна"


Меню "Настройки"


Меню "Справка"


Пользователь может перемещать и размещать окна произвольным образом. Можно закрыть часть окон, которые редко используются. Окна "паркуются" по краям главного окна. Инструментальные панели могут приобретать вертикальную или горизонтальную ориентацию. Для перемещения плавающего окна поместите курсор мыши на заголовок окна, нажмите левую кнопку и потяните. Парковка (причаливание) плавающих окон возможна по краям экранов, краям графических зон и поверх других окон в качестве страниц с закладками. Типичная конфигурация окон и панелей программы САПФИР изображена на рис.1.


Панель "Инструменты" Панель свойств инструмента Окно "Структура проекта" Окно "Свойства" Окно предварительного просмотра Главное меню Закладки графических видов Изображение модели в 3D Окно координат 3D локатор

Рис.1. Типичная конфигурация окон САПФИР

Как работать с программой САПФИР

Запустите программу. Создайте новый документ. У вас уже есть одно здание и один этаж. Пространство этого этажа вы видите на экране.


На панели "Инструменты" выберите инструмент "Стена". В верхней части экрана появились свойства инструмента. Установите способ построения "Отрезок", опция "цепочка" - отключена. Переведите мышь в графическое окно: вслед за курсором мыши передвигается локатор. Щёлкните левой кнопкой. Произошёл ввод точки. Перемещайте мышь - за локатором тянется изображение стены. Щёлкните левой кнопкой ещё раз. Произошёл ввод второй точки отрезка. Теперь на экране вы видите модель стены. Попробуйте ещё. Попробуйте выбрать другой материал стены, задать другую толщину, другой способ привязки относительно осевой линии. Если включена опция "цепочка", происходит ввод стены, состоящей из последовательной цепочки сегментов, путём ввода нескольких промежуточных точек. Enter - завершить цепочку.


Нажмите правую кнопку мыши, когда курсор в графическом окне. Не отпуская правую кнопку подвигайте мышь - происходит поворот камеры для осмотра модели с различных ракурсов. Выберите удобный ракурс. Это можно делать и в процессе построения.


На панели "Инструменты" выберите инструмент "Колонна". Переведите курсор в графическое окно. За локатором перемещается модель колонны. Щёлкните левой кнопкой - вы поставили колонну в текущем положении локатора. Поставьте ещё несколько колонн.


На панели "Инструменты" выберите инструмент "Указывание". Наведите курсор, как прицел, на изображение любой стены. Щёлкните левой кнопкой. Указанный объект выделяется (подсвечивается зелёным цветом). Вверху показаны свойства стены. Аналогично выделите колонну - вверху теперь показаны свойства колонны. Вы можете менять свойства (параметры) выделенного объекта.


Выделите стену. Нажмите левую кнопку мыши и, не отпуская, начните перемещать мышь. Выделенный элемент пришёл в движение. Теперь отпустите левую кнопку. Продолжайте перемещать мышь - объект перемещается в пространстве, следуя движениям локатора. Чтобы зафиксировать перемещаемый объект в новом положении, выполните щелчок левой кнопкой.


Аналитическое представление модели

Нажмите кнопку "Аналитическая модель". Теперь вы видите стены как плоские пластины, а колонны, как стержни. В этом виде тоже можно выполнять построения и редактирование. Отожмите кнопку - и вы снова увидите архитектурное представление модели "в теле".


Обратитесь к окну "Структура". Найдите строку "этаж #1", наведите на неё курсор мыши щёлкните правой кнопкой, чтобы раскрыть контекстное меню. Выберите в меню команду "Показать план этажа". Открывается новое графическое окно, в котором представлен вид этажа в плане. Если сечение стены на плане не заштриховано, проверьте материал стены. Для этого выделите стену для редактирования путём указывания и выберите требуемый материал.
На плане можно нанести обозначения и размеры, текстовые надписи, начертить линии и заштрихованные области. Эти дополнительные элементы не попадут в 3D, будут видны только на плане.


Когда на экране план этажа, обратитесь к окну "Листы". Выберите в списке пункт "Чертежи". Нажмите команду "Новый лист". В диалоге выберите опцию "поместить на лист План этаж #1", ОК. Вы получили модель чертёжного листа, на котором размещён вид документирования - план этажа. На листе чертежа можно дополнительно вычертить линии, заштрихованные области и нанести текст.
Попробуйте вносить изменения в вид документирования: начертить или удалить линии на плане этажа. Наблюдайте при этом изменения на листе чертежа.
Попробуйте вносить изменения в пространственную модель: достроить новые стены, удалить построенные ранее или назначить им другой материал. Наблюдайте при этом изменения на виде документирования (плане) и на листе чертежа.
Из этих наблюдений напрашивается вывод о первичности пространственной информационной модели, выстроенной в 3D. Виды документиования и чертежи получаются на её основе как результат прямой связи. Предусмотрена и обратная связь: можно создавать и модифицировать элементы (стены, колонны и т.п.) посредством воздействия на их изображения в виде документирования. Иначе говоря, вы можете выделить и отредактировать стену на плане, и это отразится на её 3D модели.


Конструкции

Всё вышесказанное относилось, прежде всего, к архитектурно-конструктивной модели, редактирование которой осуществляется в стандартной комплектации САПФИР. В вариантах комплектации, дополненных подсистемой КОНСТРУКЦИИ, доступны дополнительные возможности.


Конструкции

По нажатию кнопки "Конструкции" на панели "Инструменты" САПФИР происходит переключение в режим КОНСТРУКЦИИ, обеспечиваемый соответствующей подсистемой. При первом (для данного проекта) включении режима предлагается диалог "Создать новую аналитическую модель", с помощью которого можно выбрать опции создания новой аналитической модели. Режим КОНСТРУКЦИИ обеспечит её дальнейшее редактирование средствами специализиарованного для постаналитики инструмента "Указывание".
Аналитическая модель создаётся на базе аналитического представления имеющейся на данный момент архитектурно-конструктивной модели. По сути, она представляет копию аналитического представления архитектурно-конструктивной модели с некоторыми дополнениями. Далее эту модель можно подвергнуть геометрической постобработке - идеализации - с целью придать ей состояние, пригодное для автоматизированной генерации на её основе расчётной схемы.

Этапы постаналитической обработки:

1.Дотягивание.
2.Выравнивание.
3.Поиск пересечений.
4.Редактирование контуров.
5.Нанесение дополнительных точек и линий, управляющих триангуляцией.
6.Выбор способа триангуляции, параметров триангуляции и собственно триангуляция.
7.Формирование расчётной схемы и запись её в файл для ПК ЛИРА-САПР.

Некоторые из этих этапов могут быть пропущены или, наоборот, повторены несколько раз. Например, для некоторых моделей (поверхности) не нужно дотягивание. Для моделей, изначально созданных в САПФИР, обычно не требуется выравнивание.

Полученный в результате файл в формате S2L передаётся в ПК ЛИРА-САПР, где выполняется прочностной расчёт, анализ и расчёт арматуры. Затем в ПК ЛИРА-САПР выполняется экспорт результатов армирования для САПФИР. После чего можно выполнять конструирование арматуры средствами подсистемы САПФИР-ЖБК.

САПФИР-ЖБК

САПФИР-ЖБК - это подсистема в составе ПК САПФИР, которая обеспечивает конструирование арматуры плиты перекрытия и диафрагмы жёсткости на основе результатов расчёта в ПК ЛИРА-САПР.

Чтобы воспользоваться преимуществами САПФИР-ЖБК, следует:

1. Построить средствами САПФИР модель здания, в которой предусмотреть плиты перекрытия и диафрагмы жёсткости из бетона. Материал этих элементов должен быть с признаком "ЖБК". При моделировании следует учесть, что направления осей X и Y системы координат будут использованы в качестве направлений размещения арматурных стержней основной и дополнительной арматуры.
Процедуры автоматизированного размещения арматуры продавливания предполагают также наличие в модели колонн.

2. В свойствах проекта выбрать нормативные документы и задать параметры, в соответствии с которыми будут вычислены контуры продавливания.
Для колонн там, где это важно, задать значение параметра "Контур продавливания" : "Автоматически". Контуры продавливания можно наблюдать на пластинах плит перекрытия в аналитическом представлении модели.

3. Используя инструменты подсистемы КОНСТРУКЦИИ сформировать расчётную схему и передать её в ПК ЛИРА-САПР.

4. В ПК ЛИРА-САПР проконтролировать и при необходимости произвести согласование осей X вдоль X и осей Y вдоль Y, назначить материал: КЭ оболочки, класс бетона, класс арматуры.

5. Выполнить конечно-элементный расчёт, расчёт на продавливание, вычислить требуемую арматуру.
Экспортировать файл результатов расчёта армирования для САПФИР.

6. В ПК САПФИР импортировать результаты, убедиться, что плиты перекрытия промаркированы надлежащим образом. Для маркировки плит используйте сервис "Марки". Марки плит используются в надписях при автоматическом формировании чертежей армирования и спецификаций.
Для назначения марок диафрагмам наблюдайте результаты в 3D виде, используйте команду меню "Создать / Обозначение / Маркировка..." для назначения одинаковой марки нескольким выделенным диафрагмам.

7. В ПК САПФИР выбрать инструмент "Указывание". Указать плиту перекрытия или диафрагму, подлежащую армированию. Нажать пиктограмму "Армирование" на панели инструмента "Перекрытие" (или "Стена").

8. Используя инструменты "Участки плит", "Продавливание", "Каркасы" выполнить конструирование продольной и поперечной арматуры, в том числе, в зонах продавливания, получить чертежи перекрытий, спецификации, ведомость расхода стали.
Используя инструменты "Зоны диафрагм", "Детали", выполнить конструирование вертикальной и горизонтальной арматуры в диафрагмах жёсткости, обрамление отверстий и усиление краёв, получить чертежи диафрагм, спецификации, ведомость расхода стали.

Конструирование арматуры плиты перекрытия производится в специальном виде документирования, который представляет "сборочный узел" плиты перекрытия. В этом виде изображаются: результаты армирования, опалубочный контур плиты, контуры проёмов и опорных элементов, а также обозначения арматуры (продольной и поперечной, каркасов) и контуры продавливания. Результаты расчёта продольного армирования отображаются в виде мозаики или в виде изополей. На фоне изображения результатов изображается опалубочный контур плиты и контуры опорных элементов. Кроме того, опционно изображается собственно модель плиты и модели опорных элементов (стен и колонн). Можно отключить видимость моделей плиты, стен и колонн. Для этого можно воспользоваться управлением слоями моделирования. Обычно такие элементы располагаются на слое "Конструктив", видимость которого следует отключить. Это позволит легко указывать и редактировать линии опалубочного контура и контуров опор.

Пятна мозаики формируются из контуров конечных элементов, окрашенных в соответствии с вычисленными значениями площади армирования. Для определения цвета используется шкала, настраиваемая пользователем. Шкала предусматривает фоновую арматуру и дополнительную. С учётом фоновой арматуры изополя выглядят как цветные пятна на изображении плиты. Цвет этих пятен показывает, сколько ещё дополнительной арматуры нужно разместить в данном месте. При размещении дополнительной араматуры проектировщик старается охватить цветное пятно резиновой рамкой. Эта рамка задаёт силовую зону, в переделах которой работают стержни. Дополнительно достраивается зона анкеровки - продления стержней. В спецификации учитывается полная длина стержней с учётом добавок на анкеровку. Расчёт анкеровки можно выполнить при помощи специальной утилиты, доступной в меню "Сервисы".

Конструирование арматуры в диафрагмах жёсткости производится в специальном виде документирования, который представляет "сборочный узел" стены, построенный на основе её развёртки (если осевая линия стены не прямая). В этом виде изображаются: результаты армирования, контур развёртки стены, контуры проёмов в соответствующих позициях, а также обозначения арматуры (вертикальной и горизонтальной). Результаты расчёта армирования отображаются в виде мозаики или в виде изополей. Если стена прямолинейная, для неё могут быть получены сечения, на которых отображаются арматурные стержни. Поэтому для полного использования возможностей построения сечений и редактирования размещения арматуры в сечении рекомендуется предварительно разбивать стены, построенные на основе ломаной осевой линии, на отдельные сегменты, осевые линии которых являются отрезками прямых.

Схемы армирования и спецификации размещаются на листах чертежей. Дополнительно на листах чертежей могут быть размещены текстовые примечания: формируемые автоматически с учётом свойств армирования данной плиты.

Для конструирования поперечной арматуры служит инструмент "Каркасы". Для автоматизированного конструирования поперечной арматуры в зонах продавливания служит инструмент "Продавливание".

Для подробного ознакомления с технологией использования САПФИР-ЖБК смотрите пример.

© «САПФИР-3D» v.2013, 2013